kernel - IPV6 fragmentation flaw
Published Jan 14, 2017
8.6
HIGHCVSS 3.0
EPSS 2.75%
Description
An issue was discovered in the IPv6 protocol specification, related to ICMP Packet Too Big (PTB) messages. (The scope of this CVE is all affected IPv6 implementations from all vendors.) The security implications of IP fragmentation have been discussed at length in [RFC6274] and [RFC7739]. An attacker can leverage the generation of IPv6 atomic fragments to trigger the use of fragmentation in an arbitrary IPv6 flow (in scenarios in which actual fragmentation of packets is not needed) and can subsequently perform any type of fragmentation-based attack against legacy IPv6 nodes that do not implement [RFC6946]. That is, employing fragmentation where not actually needed allows for fragmentation-based attack vectors to be employed, unnecessarily. We note that, unfortunately, even nodes that already implement [RFC6946] can be subject to DoS attacks as a result of the generation of IPv6 atomic fragments. Let us assume that Host A is communicating with Host B and that, as a result of the widespread dropping of IPv6 packets that contain extension headers (including fragmentation) [RFC7872], some intermediate node filters fragments between Host B and Host A. If an attacker sends a forged ICMPv6 PTB error message to Host B, reporting an MTU smaller than 1280, this will trigger the generation of IPv6 atomic fragments from that moment on (as required by [RFC2460]). When Host B starts sending IPv6 atomic fragments (in response to the received ICMPv6 PTB error message), these packets will be dropped, since we previously noted that IPv6 packets with extension headers were being dropped between Host B and Host A. Thus, this situation will result in a DoS scenario. Another possible scenario is that in which two BGP peers are employing IPv6 transport and they implement Access Control Lists (ACLs) to drop IPv6 fragments (to avoid control-plane attacks). If the aforementioned BGP peers drop IPv6 fragments but still honor received ICMPv6 PTB error messages, an attacker could easily attack the corresponding peering session by simply sending an ICMPv6 PTB message with a reported MTU smaller than 1280 bytes. Once the attack packet has been sent, the aforementioned routers will themselves be the ones dropping their own traffic.
Affected products
No data.
No data.
Red Hat Enterprise Linux 6
kernel-0:2.6.32-696.el6
Fixed · RHSA-2017:0817
Red Hat Enterprise Linux 4
kernel
Not affected
Red Hat Enterprise Linux 5
kernel
Not affected
Red Hat Enterprise Linux 7
kernel
Not affected
Red Hat Enterprise Linux 7
kernel-rt
Not affected
Red Hat Enterprise MRG 2
realtime-kernel
Not affected
| Product | Package | State | Advisory |
|---|---|---|---|
| Red Hat Enterprise Linux 6 | kernel-0:2.6.32-696.el6 | Fixed | RHSA-2017:0817 |
| Red Hat Enterprise Linux 4 | kernel | Not affected | n/a |
| Red Hat Enterprise Linux 5 | kernel | Not affected | n/a |
| Red Hat Enterprise Linux 7 | kernel | Not affected | n/a |
| Red Hat Enterprise Linux 7 | kernel-rt | Not affected | n/a |
| Red Hat Enterprise MRG 2 | realtime-kernel | Not affected | n/a |
No package ranges for this CVE.
Remediation
Red Hat statement
This issue affects the Linux kernel shipping with Red Hat Enterprise Linux 7 and MRG-2 prior to 2.6.32-440. Versions after this release have the solution applied. This issue also affects the Linux kernel packages as shipped with Red Hat Enterprise Linux 6. Future updates for the respective releases may address the issue. This issue does not not affect Red Hat Enterprise Linux 5. This has been rated as having Moderate security impact and is not currently planned to be addressed in future updates of Red Hat Enterprise Linux 5. For additional information, refer to the Red Hat Enterprise Linux Life Cycle: https://access.redhat.com/support/policy/updates/errata/.
Metrics
No CVSS v4.0 score for this CVE.
No CVSS v3.1 score for this CVE.
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H
1 other source (Red Hat) ▾
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L
AV:N/AC:L/Au:N/C:N/I:N/A:P
This CVE is not in the KEV list.
No CISA SSVC assessment for this CVE yet.
Estimated probability of exploitation in the wild in the next 30 days (FIRST EPSS). As of Oct 1, 2026.
Score over time
2022–2026- EPSS v2
- EPSS v3
- EPSS v4
- EPSS v5
Percentile over time
- EPSS v2
- EPSS v3
- EPSS v4
- EPSS v5
Table of values (10 key points)
Flat stretches are collapsed; showing up to 120 newest points.
| Date | Score | Percentile | Model |
|---|---|---|---|
| Oct 1, 2026 | 2.75% (0.02750) | 85.68th | v5 (v2026.06.15) |
| Jun 15, 2026 | 2.73% (0.02727) | 84.10th | v5 (v2026.06.15) |
| Mar 17, 2025 | 0.66% (0.00657) | 69.32th | v4 (v2025.03.14) |
| Dec 12, 2024 | 0.65% (0.00650) | 80.08th | v3 (v2023.03.01) |
| Feb 8, 2024 | 0.65% (0.00650) | 78.73th | v3 (v2023.03.01) |
| Mar 7, 2023 | 0.65% (0.00650) | 76.20th | v3 (v2023.03.01) |
| Mar 6, 2023 | 1.11% (0.01108) | 55.18th | v2 (v2022.01.01) |
| Sep 17, 2022 | 1.11% (0.01108) | 53.57th | v2 (v2022.01.01) |
| Apr 1, 2022 | 1.11% (0.01108) | 51.54th | v2 (v2022.01.01) |
| Feb 4, 2022 | 1.11% (0.01108) | 29.61th | v2 (v2022.01.01) |
References (12)
- http://rhn.redhat.com/errata/RHSA-2017-0817.html vendor-advisoryx_refsource_REDHAT
- http://www.securityfocus.com/bid/95797 vdb-entryx_refsource_BID
- http://www.securitytracker.com/id/1038256 vdb-entryx_refsource_SECTRACK
- https://access.redhat.com/security/cve/CVE-2016-10142 Vendor Advisory
- https://bugzilla.novell.com/show_bug.cgi?id=1020078
- https://bugzilla.redhat.com/show_bug.cgi?id=1415908 Issue Tracking
- https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA43730 x_refsource_CONFIRM
- https://nvd.nist.gov/vuln/detail/CVE-2016-10142
- https://support.f5.com/csp/article/K57211290?utm_source=f5support&%3Butm_medium=RSS x_refsource_CONFIRM
- https://tools.ietf.org/html/draft-ietf-6man-deprecate-atomfrag-generation-08 x_refsource_MISCThird Party Advisory
- https://tools.ietf.org/html/rfc8021 x_refsource_MISCThird Party Advisory
- https://www.cve.org/CVERecord?id=CVE-2016-10142
| Link | Providers | Tags |
|---|---|---|
| http://rhn.redhat.com/errata/RHSA-2017-0817.html | vendor-advisoryx_refsource_REDHAT | |
| http://www.securityfocus.com/bid/95797 | vdb-entryx_refsource_BID | |
| http://www.securitytracker.com/id/1038256 | vdb-entryx_refsource_SECTRACK | |
| https://access.redhat.com/security/cve/CVE-2016-10142 | Vendor Advisory | |
| https://bugzilla.novell.com/show_bug.cgi?id=1020078 | ||
| https://bugzilla.redhat.com/show_bug.cgi?id=1415908 | Issue Tracking | |
| https://kb.pulsesecure.net/articles/Pulse_Security_Advisories/SA43730 | x_refsource_CONFIRM | |
| https://nvd.nist.gov/vuln/detail/CVE-2016-10142 | ||
| https://support.f5.com/csp/article/K57211290?utm_source=f5support&%3Butm_medium=RSS | x_refsource_CONFIRM | |
| https://tools.ietf.org/html/draft-ietf-6man-deprecate-atomfrag-generation-08 | x_refsource_MISCThird Party Advisory | |
| https://tools.ietf.org/html/rfc8021 | x_refsource_MISCThird Party Advisory | |
| https://www.cve.org/CVERecord?id=CVE-2016-10142 |
Change history (0)
No recorded changes yet.